华为交换机配置命令,华为交换机配置地址命令

华为交换机配置命令,华为交换机配置地址命令

产品res7532022-09-20 19:00:0961A+A-

今天给各位分享华为交换机配置命令的知识,其中也会对华为交换机配置地址命令进行解释,如果能碰巧解决你现在面临的问题,别忘了关注本站,现在开始吧!

华为交换机基础配置命令

1、开始

建立本地配置环境华为交换机配置命令,将主机的串口通过配置电缆与以太网交换机的Console口连接。

在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为华为交换机配置命令:波特率为9600bit/s、8位数据位、1位停止位、无校验和无流控,并选择终端类型为VT100。

以太网交换机上电,终端上显示以太网交换机自检信息,自检结束后提示用户键入回车,之后将出现命令行提示符(如)。

键入命令,配置以太网交换机或查看以太网交换机运行状态。需要帮助可以随时键入"?"

2、命令视图

(1)用户视图(查看交换机的简单运行状态和统计信息):与交换机建立连接即进入

(2)系统视图(配置系统参数)[Quidway]:在用户视图下键入system-view

(3)以太网端口视图(配置以太网端口参数)[Quidway-Ethernet0/1]:在系统视图下键入interface ethernet 0/1

(4)VLAN视图(配置VLAN参数)[Quidway-Vlan1]:在系统视图下键入vlan 1

(5)VLAN接口视图(配置VLAN和VLAN汇聚对应的IP接口参数)[Quidway-Vlan-interface1]:在系统视图下键入interface vlan-interface 1

(6)本地用户视图(配置本地用户参数)[Quidway-luser-user1]:在系统视图下键入local-user user1

(7)用户界面视图(配置用户界面参数)[Quidway-ui0]:在系统视图下键入user-interface

3、其他命令

设置系统时间和时区clock time Beijing  add 8

clock datetime 12:00:00 2005/01/23

设置交换机的名称[Quidway]sysname TRAIN-3026-1[TRAIN-3026-1]

配置用户登录[Quidway]user-interface vty 0 4

[Quidway-ui-vty0]authentication-mode scheme

创建本地用户[Quidway]local-user huawei

[Quidway-luser-huawei]password simple huawei

[Quidway-luser-huawei] service-type telnet level 3

4、VLAN配置方法

『配置环境参数』

SwitchA端口E0/1属于VLAN2,E0/2属于VLAN3

『组网需求』

把交换机端口E0/1加入到VLAN2 ,E0/2加入到VLAN3

数据配置步骤

『VLAN配置流程』

(1)缺省情况下所有端口都属于VLAN 1,并且端口是access端口,一个access端口只能属于一个vlan华为交换机配置命令

(2)如果端口是access端口,则把端口加入到另外一个vlan的同时,系统自动把该端口从原来的vlan中删除掉;

(3)除了VLAN1,如果VLAN XX不存在,在系统视图下键入VLAN XX,则创建VLAN XX并进入VLAN视图;如果VLAN XX已经存在,则进入VLAN视图。

【SwitchA相关配置】

方法一:

(1)创建(进入)vlan2

[SwitchA]vlan 2

(2)将端口E0/1加入到vlan2

[SwitchA-vlan2]port ethernet 0/1

(3)创建(进入)vlan3

[SwitchA-vlan2]vlan 3

(4)将端口E0/2加入到vlan3

[SwitchA-vlan3]port ethernet 0/2

方法二:

(1)创建(进入)vlan2

[SwitchA]vlan 2

(2)进入端口E0/1视图

[SwitchA]interface ethernet 0/1

(3)指定端口E0/1属于vlan2

[SwitchA-Ethernet1]port access vlan 2

(4)创建(进入)vlan3

[SwitchA]vlan 3

(5)进入端口E0/2视图

[SwitchA]interface ethernet 0/2

(6)指定端口E0/2属于vlan3

[SwitchA-Ethernet2]port access vlan 3

测试验证

(1)使用命令disp cur可以看到端口E0/1属于vlan2,E0/2属于vlan3;

(2)使用display interface Ethernet 0/1可以看到端口为access端口,PVID为2;

(3)使用display interface Ethernet 0/2可以看到端口为access端口,PVID为3

5、交换机IP地址配置

功能需求及组网说明

『配置环境参数』

三层交换机SwitchA有两个端口ethetnet 0/1、ethernet 0/2,分别属于vlan 2、vlan 3;

以vlan 2的三层接口地址分别是1.0.0.1/24作为PC1的网关;

以vlan 3的三层接口地址分别是2.0.0.1/24作为PC2的网关;

『组网需求』

PC1和PC2通过三层接口互通

【SwitchA相关配置】

(1)创建(进入)vlan2

[Quidway]vlan 2

(2)将端口E0/1加入到vlan2

[Quidway-vlan2]port ethernet 0/1

(3)进入vlan2的虚接口

[Quidway-vlan2]interface vlan 2

(4)在vlan2的虚接口上配置IP地址

[Quidway-Vlan-interface2]ip address 1.0.0.1 255.255.255.0

(5)创建(进入)vlan3

[Quidway]vlan 3

(6)将E0/2加入到vlan3

[Quidway-vlan3]port ethernet 0/2

(7)进入vlan3的虚接口

[Quidway-vlan3]interface vlan 3

(8)在vlan3的虚接口上配置IP地址

[Quidway-Vlan-interface3]ip address 2.0.0.1 255.255.255.0

测试验证

(1)PC1和PC2都可以PING通自己的网关

(2)PC1和PC2可以相互PING通

6、端口的trunk配置

『配置环境参数』

(1)SwitchA 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchB端口E0/3互连

(2)SwitchB 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchA端口E0/3互连

『组网需求』

(1)要求SwitchA的vlan10的PC与SwitchB的vlan10的PC互通

(2)要求SwitchA的vlan20的PC与SwitchB的vlan20的PC互通

数据配置步骤

【SwitchA相关配置】

(1)创建(进入)vlan10

[SwitchA] vlan 10

(2)将E0/1加入到vlan10

[SwitchA-vlan10]port Ethernet 0/1

(3)创建(进入)vlan20

[SwitchA]vlan 20

(4)将E0/2加入到vlan20

[SwitchA-vlan20]port Ethernet 0/2

(5)实际当中一般将上行端口设置成trunk属性,允许vlan透传

[SwitchA-Ethernet0/3]port link-type trunk

(6)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值

[SwitchA-Ethernet0/3]port trunk permit vlan all

【SwitchB相关配置】

(1)创建(进入)vlan10

[SwitchB] vlan 10

(2)将E0/1加入到vlan10

[SwitchB-vlan10]port Ethernet 0/1

(3)创建(进入)vlan20

[SwitchB]vlan 20

(4)将E0/2加入到vlan20

[SwitchB-vlan20]port Ethernet 0/2

(5)实际当中一般将上行端口设置成trunk属性,允许vlan透传

[SwitchB-Ethernet0/3]port link-type trunk

(7)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值

[SwitchB-Ethernet0/3]port trunk permit vlan all

【补充说明】

(1)如果一个端口是trunk端口,则该端口可以属于多个vlan;

(2)缺省情况下trunk端口的PVID为1,可以在端口模式下通过命令port trunk pvid vlan vlanid 来修改端口的PVID;

(3)如果从trunk转发出去的数据报文的vlan id和端口的PVID一致,则该报文的VLAN信息会被剥去,这点在配置trunk端口时需要注意。

(4)一台交换机上如果已经设置了某个端口为hybrid端口,则不可以再把另外的端口设置为trunk端口。

(5)一般情况下最好指定端口允许通过哪些具体的VLAN,不要设置允许所有的VLAN通过。

测试验证

(1)SwitchA vlan10内的PC可以与SwitchB vlan10内的PC互通

(2)SwitchA vlan20内的PC可以与SwitchB vlan20内的PC互通

(3)SwitchA vlan10内的PC不能与SwitchB vlan20内的PC互通

(4)SwitchA vlan20内的PC不能与SwitchB vlan10内的PC互通

7、端口汇聚配置

『配置环境参数』

(1)交换机SwitchA和SwitchB通过以太网口实现互连。

(2)SwitchA用于互连的端口为e0/1和e0/2,SwitchB用于互连的端口为e0/1和e0/2。

『组网需求』

增加SwitchA的SwitchB的互连链路的带宽,并且能够实现链路备份,使用端口汇聚

数据配置步骤

【SwitchA交换机配置】

(1)进入端口E0/1

[SwitchA]interface Ethernet 0/1

(2)汇聚端口必须工作在全双工模式

[SwitchA-Ethernet0/1]duplex full

(3)汇聚的端口速率要求相同,但不能是自适应

[SwitchA-Ethernet0/1]speed 100

(4)进入端口E0/2

[SwitchA]interface Ethernet 0/2

(5)汇聚端口必须工作在全双工模式

[SwitchA-Ethernet0/2]duplex full

(6)汇聚的端口速率要求相同,但不能是自适应

[SwitchA-Ethernet0/2]speed 100

(7)根据源和目的MAC进行端口选择汇聚

[SwitchA]link-aggregation Ethernet 0/1 to Ethernet 0/2 both 

【SwitchB交换机配置】

[SwitchB]interface Ethernet 0/1

[SwitchB-Ethernet0/1]duplex full

[SwitchB-Ethernet0/1]speed 100

[SwitchB]interface Ethernet 0/2

[SwitchB-Ethernet0/2]duplex full

[SwitchB-Ethernet0/2]speed 100

[SwitchB]link-aggregation Ethernet 0/1 to Ethernet 0/2 both

【补充说明】

(1)同一个汇聚组中成员端口的链路类型与主端口的链路类型保持一致,即如果主端口为Trunk端口,则成员端口也为Trunk端口;如主端口的链路类型改为Access端口,则成员端口的链路类型也变为Access端口。

(2)不同的产品对端口汇聚时的起始端口号要求各有不同,请对照《操作手册》进行配置。

8、端口镜像配置

『环境配置参数』

(1)PC1接在交换机E0/1端口,IP地址1.1.1.1/24

(2)PC2接在交换机E0/2端口,IP地址2.2.2.2/24

(3)E0/24为交换机上行端口

(4)Server接在交换机E0/8端口,该端口作为镜像端口

『组网需求』

(1)通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。

根据Quidway交换机不同型号,镜像有不同方式进行配置:

基于端口的镜像 ——基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。

基于流的镜像 ——基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交换机来说这两个数据流是要分开镜像的。

S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像 

8016交换机支持基于端口的镜像

3500/3026E/3026F/3050支持基于流的镜像 

5516/6506/6503/6506R支持对入端口流量进行镜像

数据配置步骤

以Quidway S3026C为例,通过基于二层流的镜像进行配置:

(1)定义一个ACL

[SwitchA]acl num 200 

(2)定义一个规则从E0/1发送至其它所有端口的数据包

[SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interface Ethernet0/2

(3)定义一个规则从其它所有端口到E0/1端口的数据包

[SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interface Ethernet0/1

(4)将符合上述ACL的数据包镜像到E0/8

[SwitchA]mirrored-to link-group 200 interface e0/8

9、生成树STP配置

『配置环境参数』

(1)交换机SwitchA、SwitchB和SwitchC都通过GE接口互连

(2)SwitchB和SwitchC交换机是核心交换机,要求主备。

『组网需求』 

要求整个网络运行STP协议

数据配置步骤

(1)【SwitchA交换机配置】

启动生成树协议: [SwitchA]stp enable

(1)【SwitchB交换机配置】

启动生成树协议:[SwitchB]stp enable

(3)配置本桥为根桥

[SwitchB]stp root primary 

(4)【SwitchC交换机配置】

a 启动生成树协议[SwitchC]stp enable

b 配置本桥为备份根桥[SwitchC]stp root secondary

(5)【SwitchD交换机配置】

a 启动生成树协议[SwitchD]stp enable

【补充说明】

(1)缺省情况下交换机的优先级都是32768,如果想人为指定某一台交换机为根交换机,也可以通过修改优先级来实现;

(2)缺省情况下打开生成树后,所有端口都会开启生成树协议,请把接PC的端口改为边缘端口模式;

(3)如果要控制某条链路的状态可以通过设置端口的cost值来实现。

测试验证

(1)使用display stp查看交换机STP运行状态

(2)查看端口STP状态display stp interface Ethernet XX是否正确

10、Quidway交换机维护

显示系统版本信息:display version

显示诊断信息:display diagnostic-information 

显示系统当前配置:display current-configuration 

显示系统保存配置: display saved-configuration

显示接口信息:display interface

显示路由信息:display ip routing-table

显示VLAN信息:display vlan

显示生成树信息:display stp

显示MAC地址表:display mac-address

显示ARP表信息:display arp

显示系统CPU使用率:display cpu

显示系统内存使用率:display memory

显示系统日志:display log 

显示系统时钟:display clock

验证配置正确后,使用保存配置命令:save

删除某条命令,一般使用命令: undo

华为交换机查看配置的命令是什么?

华为交换机常用命令:

1、display current-configuration 显示当前配置

2、display interface GigabitEthernet 1/1/4  显示接口信息

3、display packet-filter interface GigabitEthernet 1/1/4 显示接口acl应用信息

4、display acl all 显示所有acl设置 3900系列交换机

5、display acl config all 显示所有acl设置 6500系列交换机

6、display arp 10.78.4.1  显示该ip地址的mac地址,所接交换机的端口位置

7、display cpu显示cpu信息

8、system-view 进入系统图(配置交换机),等于config t 命令

9、acl number 5000 在system-view命令后使用,进入acl配置状态

10、rule 0 deny 0806 ffff 24 0a4e0401 f 40 在上面的命令后使用,acl 配置例子

11、rule 1 permit 0806 ffff 24 000fe218ded7 f 34   //在上面的命令后使用,acl配置例子

12、interface GigabitEthernet 1/0/9   //在system-view命令后使用,进入接口配置状态

13、[86ZX-S6503-GigabitEthernet1/0/9]qos   //在上面的命令后使用,进入接口qos配置

14、[86ZX-S6503-qosb-GigabitEthernet1/0/9]packet-filter inbound user-group 5000 //在上面的命令后使用,在接口上应用进站的acl

15、[Build4-2_S3928TP-GigabitEthernet1/1/4]packet-filter outbound user-group 5001 //在接口上应用出站的acl

16、undo acl number 5000 //取消acl number 5000 的设置

17、ip route-static 0.0.0.0 0.0.0.0 10.78.1.1 preference 60   //设置路由

18、reset counters interface Ethernet 1/0/14   //重置接口信息

19、save //保存设置

20、quit //退出

华为交换机配置命令

华为交换机配置命令大全

华为三层万兆交换机最大的好处是快速,由于交换机只须识别帧中MAC地址,直接根据MAC地址产生选择转发端口算法简单,便于ASIC实现,因此转发速度极高。下面跟我一起来看看华为交换机配置命令吧!

1、开始

建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。

在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s、8位数据位、1位停止位、无校验和无流控,并选择终端类型为VT100。

以太网交换机上电,终端上显示以太网交换机自检信息,自检结束后提示用户键入回车,之后将出现命令行提示符(如)。

键入命令,配置以太网交换机或查看以太网交换机运行状态。需要帮助可以随时键入"?"

2、命令视图

(1)用户视图(查看交换机的简单运行状态和统计信息):与交换机建立连接即进入

(2)系统视图(配置系统参数)[Quidway]:在用户视图下键入system-view

(3)以太网端口视图(配置以太网端口参数)[Quidway-Ethernet0/1]:在系统视图下键入interface

ethernet 0/1

(4)VLAN视图(配置VLAN参数)[Quidway-Vlan1]:在系统视图下键入vlan

1

(5)VLAN接口视图(配置VLAN和VLAN汇聚对应的IP接口参数)[Quidway-Vlan-interface1]:在系统视图下键入interface

vlan-interface 1

(6)本地用户视图(配置本地用户参数)[Quidway-luser-user1]:在系统视图下键入local-user

user1

(7)用户界面视图(配置用户界面参数)[Quidway-ui0]:在系统视图下键入user-interface

3、其他命令

设置系统时间和时区clock time Beijing add 8

clock datetime 12:00:00 2005/01/23

设置交换机的名称[Quidway]sysname

TRAIN-3026-1[TRAIN-3026-1]

配置用户登录[Quidway]user-interface vty 0

4

[Quidway-ui-vty0]authentication-mode

scheme

创建本地用户[Quidway]local-user huawei

[Quidway-luser-huawei]password simple huawei

[Quidway-luser-huawei] service-type telnet level 3

4、VLAN配置方法

『配置环境参数』

SwitchA端口E0/1属于VLAN2,E0/2属于VLAN3

『组网需求』

把交换机端口E0/1加入到VLAN2

,E0/2加入到VLAN3

数据配置步骤

『VLAN配置流程』

(1)缺省情况下所有端口都属于VLAN

1,并且端口是access端口,一个access端口只能属于一个vlan;

(2)如果端口是access端口,则把端口加入到另外一个vlan的同时,系统自动把该端口从原来的vlan中删除掉;

(3)除了VLAN1,如果VLAN

XX不存在,在系统视图下键入VLAN XX,则创建VLAN XX并进入VLAN视图;如果VLAN XX已经存在,则进入VLAN视图。

【SwitchA相关配置】

方法一:

(1)创建(进入)vlan2

[SwitchA]vlan

2

(2)将端口E0/1加入到vlan2

[SwitchA-vlan2]port ethernet

0/1

(3)创建(进入)vlan3

[SwitchA-vlan2]vlan 3

(4)将端口E0/2加入到vlan3

[SwitchA-vlan3]port ethernet 0/2

方法二:

(1)创建(进入)vlan2

[SwitchA]vlan

2

(2)进入端口E0/1视图

[SwitchA]interface ethernet

0/1

(3)指定端口E0/1属于vlan2

[SwitchA-Ethernet1]port access vlan

2

(4)创建(进入)vlan3

[SwitchA]vlan 3

(5)进入端口E0/2视图

[SwitchA]interface ethernet 0/2

(6)指定端口E0/2属于vlan3

[SwitchA-Ethernet2]port access vlan 3

测试验证

(1)使用命令disp

cur可以看到端口E0/1属于vlan2,E0/2属于vlan3;

(2)使用display interface Ethernet

0/1可以看到端口为access端口,PVID为2;

(3)使用display interface Ethernet

0/2可以看到端口为access端口,PVID为3

5、交换机IP地址配置

功能需求及组网说明

『配置环境参数』

三层交换机SwitchA有两个端口ethetnet 0/1、ethernet 0/2,分别属于vlan

2、vlan 3;

以vlan 2的三层接口地址分别是1.0.0.1/24作为PC1的网关;

以vlan

3的三层接口地址分别是2.0.0.1/24作为PC2的网关;

『组网需求』

PC1和PC2通过三层接口互通

【SwitchA相关配置】

(1)创建(进入)vlan2

[Quidway]vlan 2

(2)将端口E0/1加入到vlan2

[Quidway-vlan2]port ethernet

0/1

(3)进入vlan2的虚接口

[Quidway-vlan2]interface vlan

2

(4)在vlan2的虚接口上配置IP地址

[Quidway-Vlan-interface2]ip address 1.0.0.1

255.255.255.0

(5)创建(进入)vlan3

[Quidway]vlan 3

(6)将E0/2加入到vlan3

[Quidway-vlan3]port ethernet 0/2

(7)进入vlan3的虚接口

[Quidway-vlan3]interface vlan 3

(8)在vlan3的虚接口上配置IP地址

[Quidway-Vlan-interface3]ip address 2.0.0.1

255.255.255.0

测试验证

(1)PC1和PC2都可以PING通自己的网关

(2)PC1和PC2可以相互PING通

6、端口的trunk配置

『配置环境参数』

(1)SwitchA

端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchB端口E0/3互连

(2)SwitchB

端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchA端口E0/3互连

『组网需求』

(1)要求SwitchA的vlan10的PC与SwitchB的vlan10的PC互通

(2)要求SwitchA的vlan20的PC与SwitchB的vlan20的PC互通

数据配置步骤

【SwitchA相关配置】

(1)创建(进入)vlan10

[SwitchA] vlan 10

(2)将E0/1加入到vlan10

[SwitchA-vlan10]port Ethernet

0/1

(3)创建(进入)vlan20

[SwitchA]vlan 20

(4)将E0/2加入到vlan20

[SwitchA-vlan20]port Ethernet 0/2

(5)实际当中一般将上行端口设置成trunk属性,允许vlan透传

[SwitchA-Ethernet0/3]port link-type

trunk

(6)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值

[SwitchA-Ethernet0/3]port

trunk permit vlan all

【SwitchB相关配置】

(1)创建(进入)vlan10

[SwitchB] vlan

10

(2)将E0/1加入到vlan10

[SwitchB-vlan10]port Ethernet

0/1

(3)创建(进入)vlan20

[SwitchB]vlan 20

(4)将E0/2加入到vlan20

[SwitchB-vlan20]port Ethernet 0/2

(5)实际当中一般将上行端口设置成trunk属性,允许vlan透传

[SwitchB-Ethernet0/3]port link-type

trunk

(7)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值

[SwitchB-Ethernet0/3]port

trunk permit vlan

all

【补充说明】

(1)如果一个端口是trunk端口,则该端口可以属于多个vlan;

(2)缺省情况下trunk端口的PVID为1,可以在端口模式下通过命令port

trunk pvid vlan vlanid 来修改端口的PVID;

(3)如果从trunk转发出去的数据报文的`vlan

id和端口的PVID一致,则该报文的VLAN信息会被剥去,这点在配置trunk端口时需要注意。

(4)一台交换机上如果已经设置了某个端口为hybrid端口,则不可以再把另外的端口设置为trunk端口。

(5)一般情况下最好指定端口允许通过哪些具体的VLAN,不要设置允许所有的VLAN通过。

测试验证

(1)SwitchA

vlan10内的PC可以与SwitchB vlan10内的PC互通

(2)SwitchA vlan20内的PC可以与SwitchB

vlan20内的PC互通

(3)SwitchA vlan10内的PC不能与SwitchB vlan20内的PC互通

(4)SwitchA

vlan20内的PC不能与SwitchB vlan10内的PC互通

7、端口汇聚配置

『配置环境参数』

(1)交换机SwitchA和SwitchB通过以太网口实现互连。

(2)SwitchA用于互连的端口为e0/1和e0/2,SwitchB用于互连的端口为e0/1和e0/2。

『组网需求』

增加SwitchA的SwitchB的互连链路的带宽,并且能够实现链路备份,使用端口汇聚

数据配置步骤

【SwitchA交换机配置】

(1)进入端口E0/1

[SwitchA]interface Ethernet 0/1

(2)汇聚端口必须工作在全双工模式

[SwitchA-Ethernet0/1]duplex full

(3)汇聚的端口速率要求相同,但不能是自适应

[SwitchA-Ethernet0/1]speed 100

(4)进入端口E0/2

[SwitchA]interface Ethernet

0/2

(5)汇聚端口必须工作在全双工模式

[SwitchA-Ethernet0/2]duplex

full

(6)汇聚的端口速率要求相同,但不能是自适应

[SwitchA-Ethernet0/2]speed

100

(7)根据源和目的MAC进行端口选择汇聚

[SwitchA]link-aggregation Ethernet 0/1 to

Ethernet 0/2 both

【SwitchB交换机配置】

[SwitchB]interface Ethernet

0/1

[SwitchB-Ethernet0/1]duplex full

[SwitchB-Ethernet0/1]speed

100

[SwitchB]interface Ethernet 0/2

[SwitchB-Ethernet0/2]duplex

full

[SwitchB-Ethernet0/2]speed 100

[SwitchB]link-aggregation Ethernet 0/1

to Ethernet 0/2

both

【补充说明】

(1)同一个汇聚组中成员端口的链路类型与主端口的链路类型保持一致,即如果主端口为Trunk端口,则成员端口也为Trunk端口;如主端口的链路类型改为Access端口,则成员端口的链路类型也变为Access端口。

(2)不同的产品对端口汇聚时的起始端口号要求各有不同,请对照《操作手册》进行配置。

8、端口镜像配置

『环境配置参数』

(1)PC1接在交换机E0/1端口,IP地址1.1.1.1/24

(2)PC2接在交换机E0/2端口,IP地址2.2.2.2/24

华为交换机路由配置命令

华为路由器交换机配置命令:路由器命令

[Quidway]displayversion;显示版本信息

[Quidway]displaycurrent-configuration;显示当前配置

[Quidway]displayinterfaces;显示接口信息

[Quidway]displayiproute;显示路由信息

[Quidway]sysnameaabbcc;更改主机名

[Quidway]superpasswrod123456;设置口令

[Quidway]interfaceserial0;进入接口

[Quidway-serial0]ipaddress;配置端口IP地址

[Quidway-serial0]undoshutdown;激活端口

[Quidway]link-protocolhdlc;绑定hdlc协议

[Quidway]user-interfacevty04

[Quidway-ui-vty0-4]authentication-modepassword

[Quidway-ui-vty0-4]setauthentication-modepasswordsimple222

[Quidway-ui-vty0-4]userprivilegelevel3

[Quidway-ui-vty0-4]quit

[Quidway]debugginghdlcallserial0;显示所有信息

[Quidway]debugginghdlceventserial0;调试事件信息

[Quidway]debugginghdlcpacketserial0;显示包的信息

华为路由器交换机配置命令:静态路由:

[Quidway]iproute-static{interfacenumber|nexthop}[value][reject|blackhole]

例如:[Quidway]iproute-static129.1.0.01610.0.0.2

[Quidway]iproute-static129.1.0.0255.255.0.010.0.0.2

[Quidway]iproute-static129.1.0.016Serial2

[Quidway]iproute-static0.0.0.00.0.0.010.0.0.2

华为路由器交换机配置命令:动态路由:

[Quidway]rip;设置动态路由

[Quidway]ripwork;设置工作允许

[Quidway]ripinput;设置入口允许

[Quidway]ripoutput;设置出口允许

[Quidway-rip]network1.0.0.0;设置交换路由网络

[Quidway-rip]networkall;设置与所有网络交换

[Quidway-rip]peerip-address;

[Quidway-rip]summary;路由聚合

[Quidway]ripversion1;设置工作在版本1

[Quidway]ripversion2multicast;设版本2,多播方式

[Quidway-Ethernet0]ripsplit-horizon;水平分隔

[Quidway]routeridA.B.C.D;配置路由器的ID

[Quidway]ospfenable;启动OSPF协议

[Quidway-ospf]import-routedirect;引入直联路由

[Quidway-Serial0]ospfenablearea;配置OSPF区域

华为路由器交换机配置命令:标准访问列表命令格式如下:

acl[match-orderconfig|auto];默认前者顺序匹配。

rule[normal|special]{permit|deny}[sourcesource-addrsource-wildcard|any]

例:[Quidway]acl10

[Quidway-acl-10]rulenormalpermitsource10.0.0.00.0.0.255

[Quidway-acl-10]rulenormaldenysourceany

华为路由器交换机配置命令:扩展访问控制列表配置命令

配置TCP/UDP协议的扩展访问列表:

rule{normal|special}{permit|deny}{tcp|udp}source{|any}destination|any}

[operate]

配置ICMP协议的扩展访问列表:

rule{normal|special}{permit|deny}icmpsource{|any]destination{|any]

[icmp-code][logging]

华为路由器交换机配置命令:扩展访问控制列表操作符的含义

equalportnumber;等于

greater-thanportnumber;大于

less-thanportnumber;小于

not-equalportnumber;不等

rangeportnumber1portnumber2;区间

华为交换机基本配置命令明细盘点

华为交换机基本配置命令明细盘点

传统 华为交换机从网桥发展而来华为交换机配置命令,属于OSI第二层即数据链路层设备。它根据MAC地址寻址华为交换机配置命令,通过站表选择路由华为交换机配置命令,站表的建立和维护由 CISCO思科交换机自动进行。下面是我整理的关于华为交换机基本配置命令明细,希望大家认真阅读!

1:配置登录用户,口令等

//用户直行模式提示符,用户视图

system-view //进入配置视图

[Quidway] //配置视图(配置密码后必须输入密码才可进入配置视图)

[Quidway] sysname xxx //设置主机名成为xxx这里使用

[Quidway] aaa //进入aaa认证模式定义用户账户

[Quidway-aaa] local-user wds password cipher wds

[Quidway-aaa] local-user wds level 15

[Quidway-aaa] local-user wds service-type telnet terminal ssh //有时候这个命令是最先可以运

//行的,上边两个命令像password,level都是定义完vty 的

// authentication-mode aaa后才出现

[Quidway-aaa] quit

[Quidway] user-interface vty 0 4 //当时很奇怪这个命令就是找不到,最后尝试了几次才能运行

[Quidway-ui-vty0-4] authentication-mode aaa

[Quidway-ui-vty0-4] quit

2:华为S9303 VLan设置

创建vlan:

//用户直行模式提示符,用户视图

system-view //进入配置视图

[Quidway] vlan 10 //创建vlan 10,并进入vlan10配置视图,如果vlan10存在就直接进入vlan10配置视

[Quidway-vlan10] quit //回到配置视图

[Quidway] vlan 100 //创建vlan 100,并进入vlan100配置视图,如果vlan10存在就直接进入vlan100

配置视图

[Quidway-vlan100] quit //回到配置视图

将端口加入到vlan中:

[Quidway] interface GigabitEthernet2/0/1 (10G光口)

[Quidway- GigabitEthernet2/0/1] port link-type access //定义端口传输模式

[Quidway- GigabitEthernet2/0/1] port default vlan 100 //将端口加入vlan100

[Quidway- GigabitEthernet2/0/1] quit

[Quidway] interface GigabitEthernet1/0/0 //进入1号插槽上的第一个千兆网口配置视图中。0代表1号

[Quidway- GigabitEthernet1/0/0] port link-type access //定义端口传输模式

[Quidway- GigabitEthernet2/0/1] port default vlan 10 //将这个端口加入到vlan10中

[Quidway- GigabitEthernet2/0/1] quit

将多个端口加入到VLAN中

system-view

[Quidway]vlan 10

[Quidway-vlan10]port GigabitEthernet 1/0/0 to 1/0/29 //将0到29号口加入到vlan10中

[Quidway-vlan10]quit

华为下的这个命令自己现在不知道,找了下答案也没有结果。

3:设置VTP cisco专有的vlan终极协议也成为局域网干道协议,作用是十几台交换机在企业网中,配置

VLAN工作量大,可以使用VTP协议,把一台交换机配置成VTP Server, 其余交换机配置成VTP Client,这样

华为交换机配置命令他们可以自动学习到server 上的VLAN 信息

『配置环境参数』

(1)交换机SwitchA、SwitchB和SwitchC都通过GE接口互连

(2)SwitchB和SwitchC交换机是核心交换机,要求主备。

『组网需求』

要求整个网络运行STP协议

数据配置步骤

(1)【SwitchA交换机配置】

启动生成树协议: [SwitchA]stp enable

(1)【SwitchB交换机配置】

启动生成树协议:[SwitchB]stp enable

(3)配置本桥为根桥

[SwitchB]stp root primary

(4)【SwitchC交换机配置】

a 启动生成树协议[SwitchC]stp enable

b 配置本桥为备份根桥[SwitchC]stp root secondary

(5)【SwitchD交换机配置】

a 启动生成树协议[SwitchD]stp enable

【补充说明】

(1)缺省情况下交换机的优先级都是32768,如果想人为指定某一台交换机为根交换机,也可以通过修改优

先级来实现;

(2)缺省情况下打开生成树后,所有端口都会开启生成树协议,请把接PC的端口改为边缘端口模式;

(3)如果要控制某条链路的状态可以通过设置端口的cost值来实现。

测试验证

(1)使用display stp查看交换机STP运行状态

(2)查看端口STP状态display stp interface Ethernet XX是否正确

4:交换机配置IP地址

[Quidway] interface Vlanif100 // 进入vlan100接口视图与vlan 100命令进入的地方不同

[Quidway-Vlanif100] ip address 119.167.200.90 255.255.255.252 // 定义vlan100管理IP三层

交换网关路由

[Quidway-Vlanif100] quit

[Quidway] interface Vlanif10 // 进入vlan10接口视图与vlan 10命令进入的地方不同

[Quidway-Vlanif10] ip address 119.167.206.129 255.255.255.128 // 定义vlan10管理IP三层

交换网关路由

[Quidway-Vlanif10] quit

配置默认网关:

[Quidway]ip route-static 0.0.0.0 0.0.0.0 119.167.200.89 //配置默认网关。

5: 交换机保存设置和重置命令

save //保存配置信息

reset saved-configuration /重置交换机的配置

reboot //重新启动交换机

6:交换机常用的显示命令

用户视图模式下:

display current-configuration //显示现在交换机正在运行的.配置明细

display device //显示S9303各设备状态

display interface ? //显示个端口状态,用?可以查看后边跟的选项

display version //查看交换机固件版本信息

display vlan ? // 查看vlan的配置信息

7:基于端口的mac地址绑定

系统视图下

am user-bind mac-addr mac地址 ip-addr ip地址 interface 接口类型 接口序号

以太网端口视图下

interface 接口类型 接口序号

am user-bind mac-addr mac地址 ip-addr ip地址

8:配置交换机的snmp功能

[Quidway] snmp-agent community read xx //xx是组织名称,read是以只读模式查看

[Quidway] undo snmp-agent community xx //删除xx组织

[Quidway] display snmp-agent community //显示组织名

9:交换机禁ping配置

[Quidway]acl number 3000

[Quidway-acl-adv-3000]rule 1 deny icmp-type echo any //禁止所有网络ping

[Quidway-acl-adv-3000]rule 3 deny icmp source 1.1.1.1 0.0.0.15 destination 2.2.2.2 0 禁止

1.1.1.1到2.2.2.2的icmp包

[Quidway-acl-adv-3000]quit

[Quidway]interface giga1/0/20

[Quidway-GigabitEthernet1/0/20]packet-filter inbound ip-group 3000 rule 1 //将规则在接口下用

[Quidway-GigabitEthernet1/0/20]packet-filter inbound ip-group 3000 rule 3 //将规则在接口下

[Quidway-GigabitEthernet1/0/20]quit

[Quidway]interface Vlanif 100

[Quidway-Vlanif100]packet-filter inbound ip-group 3000 rule 1 //将规则在接口下用

[Quidway-Vlanif100]quit

[Quidway]interface Vlanif 10

[Quidway-Vlanif10]packet-filter inbound ip-group 3000 rule 1 //将规则在接口下用

[Quidway-Vlanif10]quit

10:恢复交换机出厂设置

reset saved-configuration /重置交换机的配置

11: 实际工作中的一个配置实例

vlan 10

quit

vlan 100

quit

interface XGigabitEthernet2/0/1 (10G光口)

port link-type access

port default vlan 100

quit

interface Vlanif100

ip address 119.187.200.90 255.255.255.252

quit

ip route-static 0.0.0.0 0.0.0.0 119.187.200.89

aaa local-user wds password cipher wds

local-user wds privilege level 15

local-user wds service-type telnet terminal ssh

quit

user-interface vty 0 4

authentication-mode aaa quit

12:端口汇聚实例

(1)交换机SwitchA和SwitchB通过以太网口实现互连。

(2)SwitchA用于互连的端口为e0/1和e0/2,SwitchB用于互连的端口为e0/1和e0/2。

『组网需求』

增加SwitchA的SwitchB的互连链路的带宽,并且能够实现链路备份,使用端口汇聚数据配置步骤

【SwitchA交换机配置】

(1)进入端口E0/1

[SwitchA]interface Ethernet 0/1

(2)汇聚端口必须工作在全双工模式

[SwitchA-Ethernet0/1]duplex full

(3)汇聚的端口速率要求相同,但不能是自适应

[SwitchA-Ethernet0/1]speed 100

(4)进入端口E0/2

[SwitchA]interface Ethernet 0/2

(5)汇聚端口必须工作在全双工模式

[SwitchA-Ethernet0/2]duplex full

(6)汇聚的端口速率要求相同,但不能是自适应

[SwitchA-Ethernet0/2]speed 100

(7)根据源和目的MAC进行端口选择汇聚

[SwitchA]link-aggregation Ethernet 0/1 to Ethernet 0/2 both

【SwitchB交换机配置】

[SwitchB]interface Ethernet 0/1

[SwitchB-Ethernet0/1]duplex full

[SwitchB-Ethernet0/1]speed 100

[SwitchB]interface Ethernet 0/2

[SwitchB-Ethernet0/2]duplex full

[SwitchB-Ethernet0/2]speed 100

[SwitchB]link-aggregation Ethernet 0/1 to Ethernet 0/2 both

【注意】

(1)同一个汇聚组中成员端口的链路类型与主端口的链路类型保持一致,即如果主端口为Trunk端口,

则成员端口也为Trunk端口;如主端口的链路类型改为Access端口,则成员端口的链路类型也变为Access

端口。

(2)不同的产品对端口汇聚时的起始端口号要求各有不同,请对照《操作手册》进行配置。

13:端口镜像配置实例

『环境配置参数』

(1)PC1接在交换机E0/1端口,IP地址1.1.1.1/24

(2)PC2接在交换机E0/2端口,IP地址2.2.2.2/24

(3)E0/24为交换机上行端口

(4)Server接在交换机E0/8端口,该端口作为镜像端口

『组网需求』

(1)通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。根据Quidway交换机不同型号,

镜像有不同方式进行配置:

基于端口的镜像 ——基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来

进行流量观测或者故障定位。

基于流的镜像 ——基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交

换机来说这两个数据流是要分开镜像的。

S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像,8016交换机支持基于端口的镜像

3500/3026E/3026F/3050支持基于流的镜像,5516/6506/6503/6506R支持对入端口流量进行镜像数据配置

步骤 以Quidway S3026C为例,通过基于二层流的镜像进行配置:

(1)定义一个ACL

[SwitchA]acl num 200

(2)定义一个规则从E0/1发送至其它所有端口的数据包

[SwitchA]rule 0 permit ingress interface Ethernet0/1 egress

interface Ethernet0/2

(3)定义一个规则从其它所有端口到E0/1端口的数据包

[SwitchA]rule 1 permit ingress interface Ethernet0/2 egress

interface Ethernet0/1

(4)将符合上述ACL的数据包镜像到E0/8

[SwitchA]mirrored-to link-group 200 interface e0/8

14:显示配置命令

显示系统版本信息:display version

显示诊断信息:display diagnostic-information

显示系统当前配置:display current-configuration

显示系统保存配置: display saved-configuration

显示接口信息:display interface

显示路由信息:display ip routing-table

显示VLAN信息:display vlan

显示生成树信息:display stp

显示MAC地址表:display mac-address

显示ARP表信息:display arp

显示系统CPU使用率:display cpu

显示系统内存使用率:display memory

显示系统日志:display log

显示系统时钟:display clock

验证配置正确后,使用保存配置命令:save

删除某条命令,一般使用命令: undo

15:trunk干道配置

『配置环境参数』

(1)SwitchA 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchB端

口E0/3互连

(2)SwitchB 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchA端

口E0/3互连

『组网需求』

(1)要求SwitchA的vlan10的PC与SwitchB的vlan10的PC互通

(2)要求SwitchA的vlan20的PC与SwitchB的vlan20的PC互通

数据配置步骤

【SwitchA相关配置】

(1)创建(进入)vlan10

[SwitchA] vlan 10

(2)将E0/1加入到vlan10

[SwitchA-vlan10]port Ethernet 0/1

(3)创建(进入)vlan20

[SwitchA]vlan 20

(4)将E0/2加入到vlan20

[SwitchA-vlan20]port Ethernet 0/2

(5)实际当中一般将上行端口设置成trunk属性,允许vlan透传

[SwitchA-Ethernet0/3]port link-type trunk

(6)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值

[SwitchA-Ethernet0/3]port trunk permit vlan all

【SwitchB相关配置】

(1)创建(进入)vlan10

[SwitchB] vlan 10

(2)将E0/1加入到vlan10

[SwitchB-vlan10]port Ethernet 0/1

(3)创建(进入)vlan20

[SwitchB]vlan 20

(4)将E0/2加入到vlan20

[SwitchB-vlan20]port Ethernet 0/2

(5)实际当中一般将上行端口设置成trunk属性,允许vlan透传

[SwitchB-Ethernet0/3]port link-type trunk

(7)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值

[SwitchB-Ethernet0/3]port trunk permit vlan all

【补充说明】

(1)如果一个端口是trunk端口,则该端口可以属于多个vlan;

(2)缺省情况下trunk端口的PVID为1,可以在端口模式下通过命令port trunk pvid vlan vlanid 来修改

端口的PVID;

(3)如果从trunk转发出去的数据报文的vlan id和端口的PVID一致,则该报文的VLAN信息会被剥去,这点

在配置trunk端口时需要注意。

(4)一台交换机上如果已经设置了某个端口为hybrid端口,则不可以再把另外的端口设置为trunk端口。

(5)一般情况下最好指定端口允许通过哪些具体的VLAN,不要设置允许所有的VLAN通过。

测试验证

(1)SwitchA vlan10内的PC可以与SwitchB vlan10内的PC互通

(2)SwitchA vlan20内的PC可以与SwitchB vlan20内的PC互通

(3)SwitchA vlan10内的PC不能与SwitchB vlan20内的PC互通

(4)SwitchA vlan20内的PC不能与SwitchB vlan10内的PC互通

;

华为交换机基本配置命令

一、单交换机VLAN划分

命令 命令解释

system 进入系统视图

system-view 进入系统视图

quit 退到系统视图

undo vlan 20 删除vlan 20

sysname 交换机命名

disp vlan 显示vlan

vlan 20 创建vlan(也可进入vlan 20)

port e1/0/1 to e1/0/5 把端口1-5放入VLAN 20 中

disp vlan 20 显示vlan里的端口20

int e1/0/24 进入端口24

port access vlan 20 把当前端口放入vlan 20

undo port e1/0/10 表示删除当前VLAN端口10

disp curr 显示当前配置

二、配置交换机支持TELNET

system 进入系统视图

sysname 交换机命名

int vlan 1 进入VLAN 1

ip address 192.168.3.100 255.255.255.0 配置IP地址

user-int vty 0 4 进入虚拟终端

authentication-mode password (aut password) 设置口令模式

set authentication password simple 222 (set aut pass sim 222) 设置口令

user privilege level 3(use priv lev 3) 配置用户级别

disp current-configuration (disp cur) 查看当前配置

disp ip int 查看交换机VLAN IP配置

删除配置必须退到用户模式

reset saved-configuration(reset saved) 删除配置

reboot 重启交换机

三、跨交换机VLAN的通讯

在sw1上:

vlan 10 建立VLAN 10

int e1/0/5 进入端口5

port access vlan 10 把端口5加入vlan 10

vlan 20 建立VLAN 20

int e1/0/15 进入端口15

port access vlan 20 把端口15加入VLAN 20

int e1/0/24 进入端口24

port link-type trunk 把24端口设为TRUNK端口

port trunk permit vlan all 同上

在SW2上:

vlan 10 建立VLAN 10

int e1/0/20 进入端口20

port access vlan 10 把端口20放入VLAN 10

int e1/0/24 进入端口24

port link-type trunk 把24端口设为TRUNK端口

port trunk permit vlan all (port trunk permit vlan 10 只能为vlan 10使用)24端口为所有VLAN使用

disp int e1/0/24 查看端口24是否为TRUNK

undo port trunk permit vlan all 删除该句

四、路由的配置命令

system 进入系统模式

sysname 命名

int e1/0 进入端口

ip address 192.168.3.100 255.255.255.0 设置IP

undo shutdown 打开端口

disp ip int e1/0 查看IP接口情况

disp ip int brief 查看IP接口情况

user-int vty 0 4 进入口令模式

authentication-mode password(auth pass) 进入口令模式

set authentication password simple 222 37 设置口令

user privilege level 3 进入3级特权

save 保存配置

reset saved-configuration 删除配置(用户模式下运行)

undo shutdown 配置远程登陆密码

int e1/4

ip route 192.168.3.0(目标网段) 255.255.255.0 192.168.12.1(下一跳:下一路由器的接口) 静态路由

ip route 0.0.0.0 0.0.0.0 192.168.12.1 默认路由

disp ip rout 显示路由列表

华3C AR-18

E1/0(lan1-lan4)

E2/0(wan0)

E3/0(WAN1)

路由器连接使用直通线。wan0接wan0或wan1接wan1

计算机的网关应设为路由器的接口地址。

五、三层交换机配置VLAN-VLAN通讯

sw1(三层交换机):

system 进入视图

sysname 命名

vlan 10 建立VLAN 10

vlan 20 建立VLAN 20

int e1/0/20 进入端口20

port access vlan 10 把端口20放入VLAN 10

int e1/0/24 进入24端口

port link-type trunk 把24端口设为TRUNK端口

port trunk permit vlan all (port trunk permit vlan 10 只能为vlan 10使用)24端口为所有VLAN使用

sw2:

vlan 10

int e1/0/5

port access vlan 10

int e1/0/24

port link-type trunk 把24端口设为TRUNK端口

port trunk permit vlan all (port trunk permit vlan 10 只能为vlan 10使用)24端口为所有VLAN使用

sw1(三层交换机):

int vlan 10 创建虚拟接口VLAN 10

ip address 192.168.10.254 255.255.255.0 设置虚拟接口VLAN 10的地址

int vlan 20 创建虚拟接口VLAN 20

ip address 192.168.20.254 255.255.255.0 设置虚拟接口IP VLAN 20的`地址

注意:vlan 10里的计算机的网关设为 192.168.10.254

vlan 20里的计算机的网关设为 192.168.20.254

六、动态路由RIP

R1:

int e1/0 进入e1/0端口

ip address 192.168.3.1 255.255.255.0 设置IP

int e2/0 进入e2/0端口

ip adress 192.168.5.1 255.255.255.0 设置IP

rip 设置动态路由

network 192.168.5.0 定义IP

network 192.168.3.0 定义IP

disp ip rout 查看路由接口

R2:

int e1/0 进入e1/0端口

ip address 192.168.4.1 255.255.255.0 设置IP

int e2/0 进入e2/0端口

ip adress 192.168.5.2 255.255.255.0 设置IP

rip 设置动态路由

network 192.168.5.0 定义IP

network 192.168.4.0 定义IP

disp ip rout 查看路由接口

(注意:两台PC机的网关设置PC1 IP:192.168.3.1 PC2 IP:192.168.4.1)

七、IP访问列表

int e1/0

ip address 192.168.3.1 255.255.255.0

int e2/0

ip address 192.168.1.1 255.255.255.0

int e3/0

ip address 192.168.2.1 255.255.255.0

acl number 2001 (2001-2999属于基本的访问列表)

rule 1 deny source 192.168.1.0 0.0.0.255 (拒绝地址192.168.1.0网段的数据通过)

rule 2 permit source 192.168.3.0 0.0.0.255(允许地址192.168.3.0网段的数据通过)

以下是把访问控制列表在接口下应用:

firewall enable

firewall default permit

int e3/0

firewall packet-filter 2001 outbound

disp acl 2001 显示信息

undo acl number 2001 删除2001控制列表

扩展访问控制列表

acl number 3001

rule deny tcp source 192.168.3.0 0.0.0.255 destination 192.168.2.0 0.0.0.255 destination-port eq ftp

必须在r-acl-adv-3001下才能执行

rule permit ip source an destination any (rule permit ip)

int e3/0

firewall enable 开启防火墙

firewall packet-filter 3001 inbound

必须在端口E3/0下才能执行

八、命令的标准访问IP列表(三层交换机):

允许A组机器访问服务器内资料,不允许访问B组机器(服务器没有限制)

sys

vlan 10

name server

vlan 20

name teacher

vlan 30

name student

int e1/0/5

port access vlan 10

int e1/0/10

port access vlan 20

int e1/0/15

port access vlan 30

int vlan 10

ip address 192.168.10.1 255.255.255.0

undo sh

int vlan 20

ip address 192.168.20.1 255.255.255.0

int vlan 30

ip address 192.168.30.1 255.255.255.0

acl number 2001

rule 1 deny source 192.168.30.0 0.0.0.255

rule 2 permit source any

disp acl 2001 查看2001列表

int e1/0/10

port access vlan 20

packet-filter outbound ip-group 2001 rule 1

出口

九、允许A机器访问B机器的FTP但不允许访问WWW,C机器没有任何限制。

vlan 10

vlan 20

vlan 30

int e1/0/5

port access vlan 10

int e1/0/10

port access vlan 20

int e1/0/15

port access vlan 30

int vlan 10

ip address 192.168.10.1 255.255.255.0

undo sh

int vlan 20

ip address 192.168.20.1 255.255.255.0

int vlan 30

ip address 192.168.30.1 255.255.255.0

acl number 3001

rule 1 deny tcp source 192.168.30.0 0.0.0.255 destination 192.168.10.0 0.0.0.255 destination-port eq www

int e1/0/15

packet-filter inbound ip-group 3001 rule 1

进口

十、NAT地址转换(单一静态一对一地址转换)

R1:

sys

sysname R1

int e1/0

ip address 192.168.3.1 255.255.255.0

int e2/0

ip address 192.1.1.1 255.255.255.0

R2:

sys

sysname R2

int e2/0

ip address 192.1.1.2 255.255.255.0

int e1/0

ip address 10.80.1.1 255.255.255.0

回到R1:

nat static 192.168.3.1 192.1.1.1

int e2/0

nat outbound static

ip route 0.0.0.0 0.0.0.0 192.1.1.2

十一、NAT内部整网段地址转换

R1:

sys

sysname R1

int e1/0

ip address 192.168.3.1 255.255.255.0

int e2/0

ip address 192.1.1.1 255.255.255.0

acl number 2008

rule 0 permit source 192.168.3.0 0.0.0.255

rule 1 deny

quit

int e2/0

nat outbound 2008

quit

ip route-static 0.0.0.0 0.0.0.0 192.1.1.2 preference 60

华为交换机配置命令的介绍就聊到这里吧,感谢你花时间阅读本站内容,更多关于华为交换机配置地址命令、华为交换机配置命令的信息别忘了在本站进行查找喔。

点击这里复制本文地址

威鹰网 © All Rights Reserved.  Copyright Your WebSite.Some Rights Reserved.